const regex = /^[.]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[.]+', 'gm')
const str = `x8.ext.indeed.com
yk1.ext.indeed.com
za.indeed.com
zera.ext.indeed.com
.envoy.eastus2.qa.notjet.net
.envoy.westus.qa.notjet.net
.nomad.eastus2.qa.notjet.net
.nomad.westus.qa.notjet.net
.notjet.net
.torbit.notjet.net
artifacts.notjet.net
bamf.notjet.net
bamfdb.notjet.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}