using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MyApp.(Components.Services.)<([^<>]*)>[^_]*__[^.]*.MoveNext";
string substitution = @"$1$2()";
string input = @"MyApp.Components.Services.<SomeMethodName>d__e.MoveNext";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}