$re = '/MyApp.(Components.Services.)<([^<>]*)>[^_]*__[^.]*.MoveNext/m';
$str = 'MyApp.Components.Services.<SomeMethodName>d__e.MoveNext';
$subst = "$1$2()";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;