const regex = /MyApp.(Components.Services.)<([^<>]*)>[^_]*__[^.]*.MoveNext/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('MyApp.(Components.Services.)<([^<>]*)>[^_]*__[^.]*.MoveNext', 'gm')
const str = `MyApp.Components.Services.<SomeMethodName>d__e.MoveNext`;
const subst = `$1$2()`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);