using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<A HREF=""(?<url>.*)"">";
string input = @"<A HREF=""/data/client/Action.log"">Action.log</A><br> 6/8/2015 3:45 PM ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}