$re = '/<A HREF="(?<url>.*)">/';
$str = '<A HREF="/data/client/Action.log">Action.log</A><br> 6/8/2015 3:45 PM ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);