package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<A HREF="(?<url>.*)">`)
var str = `<A HREF="/data/client/Action.log">Action.log</A><br> 6/8/2015 3:45 PM `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}