import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\.[1-9][0-9]?|\\d{1,13}(?:\\.\\d{1,2})?|.\\d{2})$";
final String string = "0\n"
+ "0.5\n"
+ "1.55\n"
+ ".5\n"
+ "1234567890123\n"
+ "1234567890123.5\n"
+ "1234567890123.00\n"
+ ".01\n\n"
+ ".\n"
+ ".,\n"
+ ".0\n"
+ "1.234\n"
+ "5.\n"
+ "12345678901234\n"
+ "12345678901234.56\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}