import re
regex = re.compile(r"^(?:\.[1-9][0-9]?|\d{1,13}(?:\.\d{1,2})?|.\d{2})$", flags=re.MULTILINE)
test_str = ("0\n"
"0.5\n"
"1.55\n"
".5\n"
"1234567890123\n"
"1234567890123.5\n"
"1234567890123.00\n"
".01\n\n"
".\n"
".,\n"
".0\n"
"1.234\n"
"5.\n"
"12345678901234\n"
"12345678901234.56\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")