$re = '/^(?:\.[1-9][0-9]?|\d{1,13}(?:\.\d{1,2})?|.\d{2})$/m';
$str = '0
0.5
1.55
.5
1234567890123
1234567890123.5
1234567890123.00
.01
.
.,
.0
1.234
5.
12345678901234
12345678901234.56
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);