import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*@\\*\\/([^*]+?)(\\/\\*@\\*\\/)";
final String string = "contactCell.headline = </span><span class=\"s3\">/*@*/"Headline toBeReplaced by PropertyBag Entry"/*@*/</span><span class=\"s1\">\n"
+ " contactCell.headline = /*@*/</span><span class=\"s4\">4711/*@*/</span><span class=\"s1\"> \n\n\n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span>someThing<span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">\n\n\n\n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing2</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing3</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">\n\n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
+ " </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
+ " </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}