import re
regex = re.compile(r"\/\*@\*\/([^*]+?)(\/\*@\*\/)", flags=re.MULTILINE)
test_str = ("contactCell.headline = </span><span class=\"s3\">/*@*/"Headline toBeReplaced by PropertyBag Entry"/*@*/</span><span class=\"s1\">\n"
" contactCell.headline = /*@*/</span><span class=\"s4\">4711/*@*/</span><span class=\"s1\"> \n\n\n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span>someThing<span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">\n\n\n\n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing2</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing3</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">\n\n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> \n\n"
" </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\"> \n"
" </span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\"> \n"
" </span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")