// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/\*@\*\/([^*]+?)(\/\*@\*\/)").unwrap();
let string = "contactCell.headline = </span><span class=\"s3\">/*@*/"Headline toBeReplaced by PropertyBag Entry"/*@*/</span><span class=\"s1\">
contactCell.headline = /*@*/</span><span class=\"s4\">4711/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span>someThing<span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing2</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing3</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\"> </span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">17.5</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@BEGIN showFloatValue*/</span><span class=\"s1\">
</span><span class=\"s0\">val </span><span class=\"s1\">floatValue = </span><span class=\"s2\">/*@*/</span><span class=\"s3\">someThing</span><span class=\"s2\">/*@*/</span><span class=\"s1\">
</span><span class=\"s2\">/*@END showFloatValue*/</span><span class=\"s1\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}