#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Z0-9]+(?:-[A-Z0-9]+)?)?$"
Local $sString = "_A" & @CRLF & _
"B2_" & @CRLF & _
"A--B" & @CRLF & _
"#12" & @CRLF & _
"" & @CRLF & _
"A" & @CRLF & _
"A-B" & @CRLF & _
"" & @CRLF & _
"1A" & @CRLF & _
"12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")