import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[A-Z0-9]+(?:-[A-Z0-9]+)?)?$";
final String string = "_A\n"
+ "B2_\n"
+ "A--B\n"
+ "#12\n\n"
+ "A\n"
+ "A-B\n\n"
+ "1A\n"
+ "12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}