// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[A-Z0-9]+(?:-[A-Z0-9]+)?)?$").unwrap();
let string = "_A
B2_
A--B
#12
A
A-B
1A
12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}