#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)Rx Power[\s\t]+\(mW\)\|[\s\t]+(.*?)[\s\t]+\|.*?\|.*?\|[\s\t]+HIGH[\s\t]+(.*?)[\s\t]+\|[\s\t]+(.*?)[\s\t]+\|.*?\|.*?\|.*?\|.*?\|.*?\|[\s\t]+LOW[\s\t]+(.*?)[\s\t]+\|[\s\t]+(-?\d+)[\s\t]+\|"
Local $sString = "+--------------------- XCVR DIAGNOSTICS - Port 9 -----------------+" & @CRLF & _
"| | | Alarm | Warning |" & @CRLF & _
"| Output | Value | Threshold | Flag | Threshold | Flag |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| Temp (degC)| 27.961 | HIGH 83.000 | 0 | HIGH 80.000 | 0 |" & @CRLF & _
"| | | LOW -13.000 | 0 | LOW -10.000 | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| Tx Bias (mA)| 35.002 | HIGH 80.000 | 0 | HIGH 75.000 | 0 |" & @CRLF & _
"| | | LOW 15.000 | 0 | LOW 20.000 | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| Tx Power (mW)| 0.59930 | HIGH 1.41250 | 0 | HIGH 1.25890 | 0 |" & @CRLF & _
"| | | LOW 0.19950 | 0 | LOW 0.25120 | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| Tx Power (dBm)| -2.2236 | HIGH +1.4999 | 0 | HIGH +0.9999 | 0 |" & @CRLF & _
"| | | LOW -7.0006 | 0 | LOW -5.9998 | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| Rx Power (mW)| 0.57770 | HIGH 1.77830 | 0 | HIGH 1.58490 | 0 |" & @CRLF & _
"| | | LOW 0.01000 | 0 | LOW 0.01580 | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| Rx Power (dBm)| -2.3830 | HIGH +2.5001 | 0 | HIGH +2.0000 | 0 |" & @CRLF & _
"| | | LOW -20.0000 | 0 | LOW -18.0134 | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| Aux1 | 3.32770 | HIGH 3.63000 | 0 | HIGH 3.50000 | 0 |" & @CRLF & _
"| | | LOW 3.00000 | 0 | LOW 3.10000 | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| Aux2 | 0.00000 | HIGH 5.50000 | 0 | HIGH 5.30000 | 0 |" & @CRLF & _
"| | | LOW 4.50000 | 0 | LOW 4.70000 | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| 1.8V | | HIGH | 0 | HIGH | 0 |" & @CRLF & _
"| | | LOW | 0 | LOW | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| -5.2V | | HIGH | 0 | HIGH | 0 |" & @CRLF & _
"| | | LOW | 0 | LOW | 0 |" & @CRLF & _
"+---------------+----------+---------------+------+---------------+------+" & @CRLF & _
"| Fault/Status Flags |" & @CRLF & _
"+--------+-------+--------+--------+--------+--------+--------+----------+" & @CRLF & _
"| TX_NR | TX | TX_CDR | RX_NR | | RX_CDR | | Reset |" & @CRLF & _
"| Status | Fault | Unlock | Status | RX_LOS | Unlock | MOD_NR | Complete |" & @CRLF & _
"+--------+-------+--------+--------+--------+--------+--------+----------+" & @CRLF & _
"| 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 |" & @CRLF & _
"+--------+-------+--------+--------+--------+--------+--------+----------+" & @CRLF & _
"|APD Sply| TEC | Wavelength | Bad Ch | New Ch | UnSupp | |" & @CRLF & _
"| Fault | Fault | Unlocked | Req | Acq | TxDith | |" & @CRLF & _
"+--------+-------+-----------------+--------+--------+--------+----------+" & @CRLF & _
"| 0 | 0 | 0 | 0 | 0 | 0 | |" & @CRLF & _
"+--------+-------+-----------------+--------+--------+--------+----------+" & @CRLF & _
"| General Control/Status Signals |" & @CRLF & _
"+---------+---------+--------+--------+--------+-------+-----+-----------+" & @CRLF & _
"| TX | Soft TX | | P_Down | Soft | | RX | Data_Not |" & @CRLF & _
"| Disable | Disable | MOD_NR | State | P_Down | INTRn | LOS | _Ready |" & @CRLF & _
"+---------+---------+--------+--------+--------+-------+-----+-----------+" & @CRLF & _
"| 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 |" & @CRLF & _
"+---------+---------+--------+--------+--------+-------+-----+-----------+" & @CRLF & _
"| TX_NR | TX | TX_CDR | RX_NR | RX_CDR | Tx | Tx | |" & @CRLF & _
"| State | Fault | Unlock | State | Unlock | Tune | Dith | |" & @CRLF & _
"+---------+---------+--------+--------+--------+-------+-----+-----------+" & @CRLF & _
"| 0 | 0 | 0 | 0 | 0 | 0 | 0 | |" & @CRLF & _
"+---------+---------+--------+--------+--------+-------+-----+-----------+" & @CRLF & _
"| Module Capabilites |" & @CRLF & _
"+-------------------------+-----------------------+----------------------+" & @CRLF & _
"| Laser First Freq (GHz) | Laser Last Freq (GHz) | Grid Spacing (GHz) |" & @CRLF & _
"+-------------------------+-----------------------+----------------------+" & @CRLF & _
"| 0 | 0 | 0 |" & @CRLF & _
"+-------------------------+-----------------------+----------------------+" & @CRLF & _
"| Frequency Channel Control |" & @CRLF & _
"+---------------------------------+--------------------------------------+" & @CRLF & _
"| Channel Number Set | Frequency Error (GHz) |" & @CRLF & _
"+---------------------------------+--------------------------------------+" & @CRLF & _
"| 0 | 0 |" & @CRLF & _
"+---------------------------------+--------------------------------------+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")