# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)Rx Power[\s\t]+\(mW\)\|[\s\t]+(.*?)[\s\t]+\|.*?\|.*?\|[\s\t]+HIGH[\s\t]+(.*?)[\s\t]+\|[\s\t]+(.*?)[\s\t]+\|.*?\|.*?\|.*?\|.*?\|.*?\|[\s\t]+LOW[\s\t]+(.*?)[\s\t]+\|[\s\t]+(-?\d+)[\s\t]+\|"
test_str = ("+--------------------- XCVR DIAGNOSTICS - Port 9 -----------------+\n"
"| | | Alarm | Warning |\n"
"| Output | Value | Threshold | Flag | Threshold | Flag |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| Temp (degC)| 27.961 | HIGH 83.000 | 0 | HIGH 80.000 | 0 |\n"
"| | | LOW -13.000 | 0 | LOW -10.000 | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| Tx Bias (mA)| 35.002 | HIGH 80.000 | 0 | HIGH 75.000 | 0 |\n"
"| | | LOW 15.000 | 0 | LOW 20.000 | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| Tx Power (mW)| 0.59930 | HIGH 1.41250 | 0 | HIGH 1.25890 | 0 |\n"
"| | | LOW 0.19950 | 0 | LOW 0.25120 | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| Tx Power (dBm)| -2.2236 | HIGH +1.4999 | 0 | HIGH +0.9999 | 0 |\n"
"| | | LOW -7.0006 | 0 | LOW -5.9998 | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| Rx Power (mW)| 0.57770 | HIGH 1.77830 | 0 | HIGH 1.58490 | 0 |\n"
"| | | LOW 0.01000 | 0 | LOW 0.01580 | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| Rx Power (dBm)| -2.3830 | HIGH +2.5001 | 0 | HIGH +2.0000 | 0 |\n"
"| | | LOW -20.0000 | 0 | LOW -18.0134 | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| Aux1 | 3.32770 | HIGH 3.63000 | 0 | HIGH 3.50000 | 0 |\n"
"| | | LOW 3.00000 | 0 | LOW 3.10000 | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| Aux2 | 0.00000 | HIGH 5.50000 | 0 | HIGH 5.30000 | 0 |\n"
"| | | LOW 4.50000 | 0 | LOW 4.70000 | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| 1.8V | | HIGH | 0 | HIGH | 0 |\n"
"| | | LOW | 0 | LOW | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| -5.2V | | HIGH | 0 | HIGH | 0 |\n"
"| | | LOW | 0 | LOW | 0 |\n"
"+---------------+----------+---------------+------+---------------+------+\n"
"| Fault/Status Flags |\n"
"+--------+-------+--------+--------+--------+--------+--------+----------+\n"
"| TX_NR | TX | TX_CDR | RX_NR | | RX_CDR | | Reset |\n"
"| Status | Fault | Unlock | Status | RX_LOS | Unlock | MOD_NR | Complete |\n"
"+--------+-------+--------+--------+--------+--------+--------+----------+\n"
"| 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 |\n"
"+--------+-------+--------+--------+--------+--------+--------+----------+\n"
"|APD Sply| TEC | Wavelength | Bad Ch | New Ch | UnSupp | |\n"
"| Fault | Fault | Unlocked | Req | Acq | TxDith | |\n"
"+--------+-------+-----------------+--------+--------+--------+----------+\n"
"| 0 | 0 | 0 | 0 | 0 | 0 | |\n"
"+--------+-------+-----------------+--------+--------+--------+----------+\n"
"| General Control/Status Signals |\n"
"+---------+---------+--------+--------+--------+-------+-----+-----------+\n"
"| TX | Soft TX | | P_Down | Soft | | RX | Data_Not |\n"
"| Disable | Disable | MOD_NR | State | P_Down | INTRn | LOS | _Ready |\n"
"+---------+---------+--------+--------+--------+-------+-----+-----------+\n"
"| 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 |\n"
"+---------+---------+--------+--------+--------+-------+-----+-----------+\n"
"| TX_NR | TX | TX_CDR | RX_NR | RX_CDR | Tx | Tx | |\n"
"| State | Fault | Unlock | State | Unlock | Tune | Dith | |\n"
"+---------+---------+--------+--------+--------+-------+-----+-----------+\n"
"| 0 | 0 | 0 | 0 | 0 | 0 | 0 | |\n"
"+---------+---------+--------+--------+--------+-------+-----+-----------+\n"
"| Module Capabilites |\n"
"+-------------------------+-----------------------+----------------------+\n"
"| Laser First Freq (GHz) | Laser Last Freq (GHz) | Grid Spacing (GHz) |\n"
"+-------------------------+-----------------------+----------------------+\n"
"| 0 | 0 | 0 |\n"
"+-------------------------+-----------------------+----------------------+\n"
"| Frequency Channel Control |\n"
"+---------------------------------+--------------------------------------+\n"
"| Channel Number Set | Frequency Error (GHz) |\n"
"+---------------------------------+--------------------------------------+\n"
"| 0 | 0 |\n"
"+---------------------------------+--------------------------------------+")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.