$re = '/(?s)Rx Power[\s\t]+\(mW\)\|[\s\t]+(.*?)[\s\t]+\|.*?\|.*?\|[\s\t]+HIGH[\s\t]+(.*?)[\s\t]+\|[\s\t]+(.*?)[\s\t]+\|.*?\|.*?\|.*?\|.*?\|.*?\|[\s\t]+LOW[\s\t]+(.*?)[\s\t]+\|[\s\t]+(-?\d+)[\s\t]+\|/';
$str = '+--------------------- XCVR DIAGNOSTICS - Port 9 -----------------+
| | | Alarm | Warning |
| Output | Value | Threshold | Flag | Threshold | Flag |
+---------------+----------+---------------+------+---------------+------+
+---------------+----------+---------------+------+---------------+------+
| Temp (degC)| 27.961 | HIGH 83.000 | 0 | HIGH 80.000 | 0 |
| | | LOW -13.000 | 0 | LOW -10.000 | 0 |
+---------------+----------+---------------+------+---------------+------+
| Tx Bias (mA)| 35.002 | HIGH 80.000 | 0 | HIGH 75.000 | 0 |
| | | LOW 15.000 | 0 | LOW 20.000 | 0 |
+---------------+----------+---------------+------+---------------+------+
| Tx Power (mW)| 0.59930 | HIGH 1.41250 | 0 | HIGH 1.25890 | 0 |
| | | LOW 0.19950 | 0 | LOW 0.25120 | 0 |
+---------------+----------+---------------+------+---------------+------+
| Tx Power (dBm)| -2.2236 | HIGH +1.4999 | 0 | HIGH +0.9999 | 0 |
| | | LOW -7.0006 | 0 | LOW -5.9998 | 0 |
+---------------+----------+---------------+------+---------------+------+
| Rx Power (mW)| 0.57770 | HIGH 1.77830 | 0 | HIGH 1.58490 | 0 |
| | | LOW 0.01000 | 0 | LOW 0.01580 | 0 |
+---------------+----------+---------------+------+---------------+------+
| Rx Power (dBm)| -2.3830 | HIGH +2.5001 | 0 | HIGH +2.0000 | 0 |
| | | LOW -20.0000 | 0 | LOW -18.0134 | 0 |
+---------------+----------+---------------+------+---------------+------+
| Aux1 | 3.32770 | HIGH 3.63000 | 0 | HIGH 3.50000 | 0 |
| | | LOW 3.00000 | 0 | LOW 3.10000 | 0 |
+---------------+----------+---------------+------+---------------+------+
| Aux2 | 0.00000 | HIGH 5.50000 | 0 | HIGH 5.30000 | 0 |
| | | LOW 4.50000 | 0 | LOW 4.70000 | 0 |
+---------------+----------+---------------+------+---------------+------+
| 1.8V | | HIGH | 0 | HIGH | 0 |
| | | LOW | 0 | LOW | 0 |
+---------------+----------+---------------+------+---------------+------+
| -5.2V | | HIGH | 0 | HIGH | 0 |
| | | LOW | 0 | LOW | 0 |
+---------------+----------+---------------+------+---------------+------+
| Fault/Status Flags |
+--------+-------+--------+--------+--------+--------+--------+----------+
| TX_NR | TX | TX_CDR | RX_NR | | RX_CDR | | Reset |
| Status | Fault | Unlock | Status | RX_LOS | Unlock | MOD_NR | Complete |
+--------+-------+--------+--------+--------+--------+--------+----------+
| 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 |
+--------+-------+--------+--------+--------+--------+--------+----------+
|APD Sply| TEC | Wavelength | Bad Ch | New Ch | UnSupp | |
| Fault | Fault | Unlocked | Req | Acq | TxDith | |
+--------+-------+-----------------+--------+--------+--------+----------+
| 0 | 0 | 0 | 0 | 0 | 0 | |
+--------+-------+-----------------+--------+--------+--------+----------+
| General Control/Status Signals |
+---------+---------+--------+--------+--------+-------+-----+-----------+
| TX | Soft TX | | P_Down | Soft | | RX | Data_Not |
| Disable | Disable | MOD_NR | State | P_Down | INTRn | LOS | _Ready |
+---------+---------+--------+--------+--------+-------+-----+-----------+
| 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 |
+---------+---------+--------+--------+--------+-------+-----+-----------+
| TX_NR | TX | TX_CDR | RX_NR | RX_CDR | Tx | Tx | |
| State | Fault | Unlock | State | Unlock | Tune | Dith | |
+---------+---------+--------+--------+--------+-------+-----+-----------+
| 0 | 0 | 0 | 0 | 0 | 0 | 0 | |
+---------+---------+--------+--------+--------+-------+-----+-----------+
| Module Capabilites |
+-------------------------+-----------------------+----------------------+
| Laser First Freq (GHz) | Laser Last Freq (GHz) | Grid Spacing (GHz) |
+-------------------------+-----------------------+----------------------+
| 0 | 0 | 0 |
+-------------------------+-----------------------+----------------------+
| Frequency Channel Control |
+---------------------------------+--------------------------------------+
| Channel Number Set | Frequency Error (GHz) |
+---------------------------------+--------------------------------------+
| 0 | 0 |
+---------------------------------+--------------------------------------+';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);