#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[0-9]{2}\K[AP]M"
Local $sString = "2013/11/14 06:52:38AM" & @CRLF & _
"2013/11/24 07:52:40PM"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)