$re = '/[0-9]{2}\K[AP]M/m';
$str = '2013/11/14 06:52:38AM
2013/11/24 07:52:40PM';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;