const regex = /[0-9]{2}\K[AP]M/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{2}\\K[AP]M', 'gm')
const str = `2013/11/14 06:52:38AM
2013/11/24 07:52:40PM`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);