#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([+]{0,2}?)?([+]{0,2}?)?([0-9 ]+)?)$"
Local $sString = "508 736 756" & @CRLF & _
"505050505" & @CRLF & _
"+48 505 505 505" & @CRLF & _
"(+48) 505 505 505" & @CRLF & _
"++48 505 505 505" & @CRLF & _
"(++48) 505 505 505" & @CRLF & _
"(23)692 36 99" & @CRLF & _
"23 692 36 99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")