import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([+]{0,2}?)?([+]{0,2}?)?([0-9 ]+)?)$";
final String string = "508 736 756\n"
+ "505050505\n"
+ "+48 505 505 505\n"
+ "(+48) 505 505 505\n"
+ "++48 505 505 505\n"
+ "(++48) 505 505 505\n"
+ "(23)692 36 99\n"
+ "23 692 36 99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}