package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([+]{0,2}?)?([+]{0,2}?)?([0-9 ]+)?)$`)
var str = `508 736 756
505050505
+48 505 505 505
(+48) 505 505 505
++48 505 505 505
(++48) 505 505 505
(23)692 36 99
23 692 36 99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}