#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<a ([^>]*)>([^<]*)(<\/?br\/?>)+([^<]*)<\/a"
Local $sString = "<h1>Finantza-trebakuntza</h1>" & @CRLF & _
"<p>" & @CRLF & _
"Izaera praktikoa duten ikastaro-eskaintza osatua egiten du, enpresaren kudeaketa ekonomiko-finantzarioaren eremu desberdinen inguruan eta bere beharretara egokitua. " & @CRLF & _
"</p>" & @CRLF & _
"<ul class='cuadrados2 tres clearfix'><li class='lineas3'>Finantza- trebakuntzan aitzindariak</li>" & @CRLF & _
" <li class='lineas3'>18.500<br></br>" & @CRLF & _
" parte hartzaile baino gehiago</li>" & @CRLF & _
" <li class='lineas3'>Ikastaro<br></br>" & @CRLF & _
" praktiko eta <br></br>" & @CRLF & _
" eraginkorrak</li>" & @CRLF & _
"</ul><ul class='cuadrados dos clearfix'><li class='lineas2'><a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Finantza-Ikasgelako-ikastaroak/316.aspx'>Finantza Ikasgelako<br></br>" & @CRLF & _
" ikastaroak</a></li>" & @CRLF & _
" <li class='lineas1'><a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Ikastaro-presentzialak/338.aspx'>Ikastaro ez presentzialak</a></li>" & @CRLF & _
"</ul><ul class='cuadrados dos clearfix'><li class='lineas1'><a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Company-trebakuntza-ikastaroak/337.aspx'>Trebakuntza in-company</a></li>" & @CRLF & _
" <li class='lineas2'><a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Finantza-Zuzendaritzako-Programa-Exekutiboa/336.aspx'>Finantza Zuzendaritzako Programa Exekutiboa</a></li>" & @CRLF & _
"</ul><br></br>" & @CRLF & _
" <a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/finantza-zuzendaritzako-programa-exekutiboa/pedf-jardunaldi-informatiboak/540.aspx' title='PEDF'><img src='http://www.elkargi.es/uploads/images/Banners/2011/PEDF_oct_eusk_especial.jpg' alt='PEDF'></img></a><br></br></div>" & @CRLF & _
""
Local $sSubst = "<a $1>$2 $4</a"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)