re = /<a ([^>]*)>([^<]*)(<\/?br\/?>)+([^<]*)<\/a/i
str = '<h1>Finantza-trebakuntza</h1>
<p>
Izaera praktikoa duten ikastaro-eskaintza osatua egiten du, enpresaren kudeaketa ekonomiko-finantzarioaren eremu desberdinen inguruan eta bere beharretara egokitua.
</p>
<ul class=\'cuadrados2 tres clearfix\'><li class=\'lineas3\'>Finantza- trebakuntzan aitzindariak</li>
<li class=\'lineas3\'>18.500<br></br>
parte hartzaile baino gehiago</li>
<li class=\'lineas3\'>Ikastaro<br></br>
praktiko eta <br></br>
eraginkorrak</li>
</ul><ul class=\'cuadrados dos clearfix\'><li class=\'lineas2\'><a href=\'http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Finantza-Ikasgelako-ikastaroak/316.aspx\'>Finantza Ikasgelako<br></br>
ikastaroak</a></li>
<li class=\'lineas1\'><a href=\'http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Ikastaro-presentzialak/338.aspx\'>Ikastaro ez presentzialak</a></li>
</ul><ul class=\'cuadrados dos clearfix\'><li class=\'lineas1\'><a href=\'http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Company-trebakuntza-ikastaroak/337.aspx\'>Trebakuntza in-company</a></li>
<li class=\'lineas2\'><a href=\'http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Finantza-Zuzendaritzako-Programa-Exekutiboa/336.aspx\'>Finantza Zuzendaritzako Programa Exekutiboa</a></li>
</ul><br></br>
<a href=\'http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/finantza-zuzendaritzako-programa-exekutiboa/pedf-jardunaldi-informatiboak/540.aspx\' title=\'PEDF\'><img src=\'http://www.elkargi.es/uploads/images/Banners/2011/PEDF_oct_eusk_especial.jpg\' alt=\'PEDF\'></img></a><br></br></div>
'
subst = '<a $1>$2 $4</a'
result = str.sub(re, subst)
# Print the result of the substitution
puts result