import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a ([^>]*)>([^<]*)(<\\/?br\\/?>)+([^<]*)<\\/a";
final String string = "<h1>Finantza-trebakuntza</h1>\n"
+ "<p>\n"
+ "Izaera praktikoa duten ikastaro-eskaintza osatua egiten du, enpresaren kudeaketa ekonomiko-finantzarioaren eremu desberdinen inguruan eta bere beharretara egokitua. \n"
+ "</p>\n"
+ "<ul class='cuadrados2 tres clearfix'><li class='lineas3'>Finantza- trebakuntzan aitzindariak</li>\n"
+ " <li class='lineas3'>18.500<br></br>\n"
+ " parte hartzaile baino gehiago</li>\n"
+ " <li class='lineas3'>Ikastaro<br></br>\n"
+ " praktiko eta <br></br>\n"
+ " eraginkorrak</li>\n"
+ "</ul><ul class='cuadrados dos clearfix'><li class='lineas2'><a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Finantza-Ikasgelako-ikastaroak/316.aspx'>Finantza Ikasgelako<br></br>\n"
+ " ikastaroak</a></li>\n"
+ " <li class='lineas1'><a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Ikastaro-presentzialak/338.aspx'>Ikastaro ez presentzialak</a></li>\n"
+ "</ul><ul class='cuadrados dos clearfix'><li class='lineas1'><a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Company-trebakuntza-ikastaroak/337.aspx'>Trebakuntza in-company</a></li>\n"
+ " <li class='lineas2'><a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/Finantza-Zuzendaritzako-Programa-Exekutiboa/336.aspx'>Finantza Zuzendaritzako Programa Exekutiboa</a></li>\n"
+ "</ul><br></br>\n"
+ " <a href='http://elkargi2015.pre.wegetit.ws/eu/elkargi-consultores-trebakuntza/finantza-zuzendaritzako-programa-exekutiboa/pedf-jardunaldi-informatiboak/540.aspx' title='PEDF'><img src='http://www.elkargi.es/uploads/images/Banners/2011/PEDF_oct_eusk_especial.jpg' alt='PEDF'></img></a><br></br></div>\n";
final String subst = "<a $1>$2 $4</a";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}