package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:.*?-\s*(\w+)){4}`)
var str = `These.Final.Hours-AUSVERSION.2013-TEST-TESTAGAIN- YIFY.cp(tt123456).MiLLENiUM.mp4`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}