const regex = /^(?:.*?-\s*(\w+)){4}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*?-\\s*(\\w+)){4}', '')
const str = `These.Final.Hours-AUSVERSION.2013-TEST-TESTAGAIN- YIFY.cp(tt123456).MiLLENiUM.mp4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}