re = /^(?:.*?-\s*(\w+)){4}/
str = 'These.Final.Hours-AUSVERSION.2013-TEST-TESTAGAIN- YIFY.cp(tt123456).MiLLENiUM.mp4'
# Print the match result
str.match(re) do |match|
puts match.to_s
end