using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^X+(\W)X+(\W)X+$";
string substitution = @"\\1\1\\2\2\\3";
string input = @"XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}