import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^X+(\\W)X+(\\W)X+$";
final String string = "XXX-XXX-XXX\n"
+ "XX=XXXX^XXX\n"
+ "XXXXX@XX.XX";
final String subst = "\\\\1\\1\\\\2\\2\\\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}