import re
regex = re.compile(r"^X+(\W)X+(\W)X+$", flags=re.MULTILINE)
test_str = ("XXX-XXX-XXX\n"
"XX=XXXX^XXX\n"
"XXXXX@XX.XX")
subst = "\\\\1\\1\\\\2\\2\\\\3"
result = regex.sub(subst, test_str)
if result:
print(result)