$re = '/^\d+(?:\.?\d+){0,2}$/m';
$str = '10.2.15
10.11
11
111.234.43556
10..2.15
10.2..15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);