re = /^\d+(?:\.?\d+){0,2}$/m
str = '10.2.15
10.11
11
111.234.43556
10..2.15
10.2..15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end