#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\*?(?P<my_time>\d{4}-\d{2}-\d{2}\s\d{2}:\d{2}:\d{2})\*?"
Local $sString = "utility_extract10_DELTA_7082019-03-12 06:03:33" & @CRLF & _
"utility_extract10_DELTA_9362019-03-12 06:07:00" & @CRLF & _
"utility_extract11_DELTA_7082019-03-12 06:08:17" & @CRLF & _
"utility_extract11_DELTA_9362019-03-12 06:07:35" & @CRLF & _
"utility_extract12_DELTA_7082019-03-12 06:08:39" & @CRLF & _
"utility_extract13_DELTA_7082019-03-12 06:08:40" & @CRLF & _
"utility_extract13_DELTA_9362019-03-12 06:10:21" & @CRLF & _
"utility_extract14_DELTA_7082019-03-12 06:09:52" & @CRLF & _
"utility_extract1_DELTA_7082019-03-12 06:06:27" & @CRLF & _
"utility_extract1_DELTA_9362019-03-12 06:06:51"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")