import re
regex = re.compile(r"\*?(?P<my_time>\d{4}-\d{2}-\d{2}\s\d{2}:\d{2}:\d{2})\*?", flags=re.MULTILINE)
test_str = ("utility_extract10_DELTA_7082019-03-12 06:03:33\n"
"utility_extract10_DELTA_9362019-03-12 06:07:00\n"
"utility_extract11_DELTA_7082019-03-12 06:08:17\n"
"utility_extract11_DELTA_9362019-03-12 06:07:35\n"
"utility_extract12_DELTA_7082019-03-12 06:08:39\n"
"utility_extract13_DELTA_7082019-03-12 06:08:40\n"
"utility_extract13_DELTA_9362019-03-12 06:10:21\n"
"utility_extract14_DELTA_7082019-03-12 06:09:52\n"
"utility_extract1_DELTA_7082019-03-12 06:06:27\n"
"utility_extract1_DELTA_9362019-03-12 06:06:51")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")