import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*?(?P<my_time>\\d{4}-\\d{2}-\\d{2}\\s\\d{2}:\\d{2}:\\d{2})\\*?";
final String string = "utility_extract10_DELTA_7082019-03-12 06:03:33\n"
+ "utility_extract10_DELTA_9362019-03-12 06:07:00\n"
+ "utility_extract11_DELTA_7082019-03-12 06:08:17\n"
+ "utility_extract11_DELTA_9362019-03-12 06:07:35\n"
+ "utility_extract12_DELTA_7082019-03-12 06:08:39\n"
+ "utility_extract13_DELTA_7082019-03-12 06:08:40\n"
+ "utility_extract13_DELTA_9362019-03-12 06:10:21\n"
+ "utility_extract14_DELTA_7082019-03-12 06:09:52\n"
+ "utility_extract1_DELTA_7082019-03-12 06:06:27\n"
+ "utility_extract1_DELTA_9362019-03-12 06:06:51";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}