using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[id(?:=|=)(""|"|")(.*?)\1]";
string input = @"text [id="B0076VLVXG"] text [id="A0041CDEFG"] more text [id="C1234VWXYZ"] yet more text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}