$re = '/\[id(?:=|=)("|"|")(.*?)\1]/m';
$str = 'text [id="B0076VLVXG"] text [id="A0041CDEFG"] more text [id="C1234VWXYZ"] yet more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);