re = /\[id(?:=|=)("|"|")(.*?)\1]/m
str = 'text [id="B0076VLVXG"] text [id="A0041CDEFG"] more text [id="C1234VWXYZ"] yet more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end