package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\+|00)?968)?[279]\d{7}$`)
var str = `+96899999999
21111111
+96812345678
+96811111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}