$re = '/^(?:(?:\+|00)?968)?[279]\d{7}$/m';
$str = '+96899999999
21111111
+96812345678
+96811111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);