re = /^(?:(?:\+|00)?968)?[279]\d{7}$/m
str = '+96899999999
21111111
+96812345678
+96811111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end