using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?=\s)";
string substitution = @"";
string input = @"aa
aaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaa";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}