$re = '/\s(?=\s)/';
$str = 'aa
aaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaa';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;