re = /\s(?=\s)/
str = 'aa
aaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaa'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result