using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/(m\.)?vk\.com\/((club|public)(\d+)|[_.a-zA-Z0-9]{5,32})?(\?w=)?wall(-\d+)_(\d+)$";
string input = @"https://vk.com/club
https://vk.com/id
https://vk.com/id123
https://vk.com/club213560530
https://m.vk.com/club213560530
https://m.vk.com/club213560530
https://vk.com/ps4exploit?w=wall-212141395_852
https://vk.com/wall-212141395_852
https://vk.com/wall-212141395_
https://vk.com/wall1_1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}