const regex = /^https?:\/\/(m\.)?vk\.com\/((club|public)(\d+)|[_.a-zA-Z0-9]{5,32})?(\?w=)?wall(-\d+)_(\d+)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(m\\.)?vk\\.com\\\/((club|public)(\\d+)|[_.a-zA-Z0-9]{5,32})?(\\?w=)?wall(-\\d+)_(\\d+)$', 'mg')
const str = `https://vk.com/club
https://vk.com/id
https://vk.com/id123
https://vk.com/club213560530
https://m.vk.com/club213560530
https://m.vk.com/club213560530
https://vk.com/ps4exploit?w=wall-212141395_852
https://vk.com/wall-212141395_852
https://vk.com/wall-212141395_
https://vk.com/wall1_1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}